Apple Carplay

GearheadSS

Well-known member
Founding Member
Joined
Apr 18, 2022
Messages
1,675
Reaction score
1,042
Location
Greenville, Texas
Just got in my truck this morning and Carplay would not connect wirelessly. I had a message pop up on the radio that says Carplay longer works without a Wifi plan through onstar. I haven't had a data plan through Onstar in months and Carplay worked fine wirelessly yesterday. Has anyone else gotten this message?
 
Just got in my truck this morning and Carplay would not connect wirelessly. I had a message pop up on the radio that says Carplay longer works without a Wifi plan through onstar. I haven't had a data plan through Onstar in months and Carplay worked fine wirelessly yesterday. Has anyone else gotten this message?
Why you would require a data plan to
connect to CarPlay is baffling. The phone connects via WIFI to the truck itself for the data transfer and communication.

I can’t speak from experience because I pay the kings ransom of 14.99 a month for data.
 
Why you would require a data plan to
connect to CarPlay is baffling. The phone connects via WIFI to the truck itself for the data transfer and communication.

I can’t speak from experience because I pay the kings ransom of 14.99 a month for data.
You don't. It has always run off of Bluetooth connection and not wifi. I fully expect this to be some bullshit from GM to try and get more money out of customers.
 
That's interesting. Hopefully just a bug?

I sure wish GM would reconsider their stance on Apple Car Play integration on future vehicles. It's nice being able to plug in any vehicle and the infotainment is the same. Especially if you travel and rent different vehicles.

Considering how large Apple's install base is, that seems like a shortsighted move.
 
Apple Carplay worked fine for me this morning, what software version are you on?
 
Mine also worked fine this morning and I just did the "over the air update" about a week ago.
Maybe just a fluke? Did you try it again Gearhead? Seems like carplay can be "buggy" at times but usually works pretty well.
I've had my audio get stuck on "navigation volume" before and had to turn the truck off and restart it to get it to work properly. Annoying but overall have been happy with it.
 
You don't. It has always run off of Bluetooth connection and not wifi. I fully expect this to be some bullshit from GM to try and get more money out of customers.
The data stream is over Wifi. Bluetooth doesn’t have the data rate required.
 

Attachments

  • IMG_0317.png
    IMG_0317.png
    121.4 KB · Views: 25
It happened in my wife's Tahoe. Also seemed buggy last night when I drove it. Also, her OnStar membership for Tahoe seemed to dissappear from her app. However it shows in my app.

My ZR2 hasn't had many infotainment issues except the occasional pause on Siruis after start up. Also drifts in and out on Pandora, which I rarely use. However, a couple weeks ago it started having connectivity issues with Android auto. It has become less automatic and more finicky. Seemed better last couple of drives.

To my knowledge, neither vehicles had an update. Just seemed to start acting up.
 
My CarPlay can be buggy like that where it won't connect wirelessly when it was set up like that, especially if I plug it in to charge before I start the truck, but I've never gotten a message like you got.

C'mon GM, wifi and internet are two different things... quit f'n with people...!!

:mad:🤬
 
  • Like
Reactions: AXE
It happened in my wife's Tahoe. Also seemed buggy last night when I drove it. Also, her OnStar membership for Tahoe seemed to dissappear from her app. However it shows in my app.

My ZR2 hasn't had many infotainment issues except the occasional pause on Siruis after start up. Also drifts in and out on Pandora, which I rarely use. However, a couple weeks ago it started having connectivity issues with Android auto. It has become less automatic and more finicky. Seemed better last couple of drives.

To my knowledge, neither vehicles had an update. Just seemed to start acting up.
Did your phone have an update?
 
Did your phone have an update?
That is possible i got a new Samsung S23+ mid February and a couple weeks ago my wife got a new iPhone. May be some updates on both sides of the equation throwing everything off.
 
Must have been a glitch. It worked normally yesterday when I left work. It still wouldn't surprise me if GM tied this to the Onstar Data plan though. They want to cut out Android Auto and Apple Carplay anyway.
 

Most Member Reactions

Latest Posts

Back
Top