Infotainment System issues with BT/Carplay

wutang61

Well-known member
Founding Member
Joined
Feb 5, 2022
Messages
466
Reaction score
722
Location
Vero Beach
Truck has developed an interesting issue. It seems that any attempt to connect a phone, (Bluetooth, Wired, or Wireless Carplay) results in an instant crash. Having a phone connected via the USB radio connection, results in endless boot-loop restarts.

Any attempts to factory reset the radio results a crash and restart before you can "confirm" selection. Seems like its bought itself a ticket to the dealership.

Just curious if anyone has experienced issues like this. or if any TSB's have been released regarding it. The Radio in my truck has been a glitchy mess since it was new so maybe the unit itself needs replacement. I guess I will find out in about a week.
 
Truck has developed an interesting issue. It seems that any attempt to connect a phone, (Bluetooth, Wired, or Wireless Carplay) results in an instant crash. Having a phone connected via the USB radio connection, results in endless boot-loop restarts.

Any attempts to factory reset the radio results a crash and restart before you can "confirm" selection. Seems like its bought itself a ticket to the dealership.

Just curious if anyone has experienced issues like this. or if any TSB's have been released regarding it. The Radio in my truck has been a glitchy mess since it was new so maybe the unit itself needs replacement. I guess I will find out in about a week.
Trip to the dealer!
 
Truck has developed an interesting issue. It seems that any attempt to connect a phone, (Bluetooth, Wired, or Wireless Carplay) results in an instant crash. Having a phone connected via the USB radio connection, results in endless boot-loop restarts.

Any attempts to factory reset the radio results a crash and restart before you can "confirm" selection. Seems like its bought itself a ticket to the dealership.

Just curious if anyone has experienced issues like this. or if any TSB's have been released regarding it. The Radio in my truck has been a glitchy mess since it was new so maybe the unit itself needs replacement. I guess I will find out in about a week.
I had an odd issue with mine as well. The music was just consistently skipping. I thought it was a bad BT connection so I tried XM and even regular radio but the issue persisted. I ended up taking it to the dealer before attempting to factory reset and that is exactly what they did. Have not had the same problem since then. Sorry to hear it, but please let us all know what the outcome is.
 
I know that some have mentioned that if you use CarPlay, Google will not work. I just tested this in my truck and what I found is this:

1. If you press for .5 seconds the SPEECH button on the steering wheel, you get Google and you can tell Google what you want (assuming your subscription is still active)
2. If you hold that button down for 2 seconds, you get SIRI and can tell SIRI what you want

They both do work, as I suspected, as it has worked this way in other vehicles I've owned that had both Google and CarPlay. I never use Google...only CarPlay.
 
I know that some have mentioned that if you use CarPlay, Google will not work. I just tested this in my truck and what I found is this:

1. If you press for .5 seconds the SPEECH button on the steering wheel, you get Google and you can tell Google what you want (assuming your subscription is still active)
2. If you hold that button down for 2 seconds, you get SIRI and can tell SIRI what you want

They both do work, as I suspected, as it has worked this way in other vehicles I've owned that had both Google and CarPlay. I never use Google...only CarPlay.
The problem is actually comically more broken then in my original post.

Google voice assistant is non functional. If it doesn’t immediately hard lock the system when you press the button it detects no voice input. No “speech” back to the driver. Just closes as you hit cancel from the application soft locking and closing.

Hitting “subscribe” on the XM page hard locks the system and reboot results.

Hitting “agree” to “pay attention to the road” prompt that pops up occasionally hard locks and crashes. Usually takes 15-20 crash reboots to get to the Home Screen.

It’s a mess really. As much as I didn’t want the dash taken apart it needs a radio.

Also came out to a wink yesterday. Fixed itself after a key cycle and 30 min period.

Really hope these don’t turn into 36,001 mile arguments at the dealer but probably will.
 

Attachments

  • F2F3FCA7-F196-457A-8335-68B67F303AE1.jpeg
    F2F3FCA7-F196-457A-8335-68B67F303AE1.jpeg
    635.3 KB · Views: 27
The problem is actually comically more broken then in my original post.

Google voice assistant is non functional. If it doesn’t immediately hard lock the system when you press the button it detects no voice input. No “speech” back to the driver. Just closes as you hit cancel from the application soft locking and closing.

Hitting “subscribe” on the XM page hard locks the system and reboot results.

Hitting “agree” to “pay attention to the road” prompt that pops up occasionally hard locks and crashes. Usually takes 15-20 crash reboots to get to the Home Screen.

It’s a mess really. As much as I didn’t want the dash taken apart it needs a radio.
It does sound like you need a new radio my friend. You tried a factory reset and still the same old same old?
 
It does sound like you need a new radio my friend. You tried a factory reset and still the same old same old?
But wait! There’s more! You go into settings and hit factory reset, the system crashes instantly on the “confirm” screen and restarts.

Really can’t make this stuff up.

But I knew going into this truck that any and all problems would be electrical in nature from it being first run of Global B in the platform.
 
But wait! There’s more! You go into settings and hit factory reset, the system crashes instantly on the “confirm” screen and restarts.

Really can’t make this stuff up.

But I knew going into this truck that any and all problems would be electrical in nature from it being first run of Global B in the platform.
Well that really sucks my friend. May not be a Global B issue at all...just a crap radio that needs to be replaced. Keep us posted!
 
I’ll agree, it sucks and it does sound like a new radio is in order.

This may not help you, but maybe someone else reading this thread. I had a few “electrical oddities” when I first got my truck back in May. When I was under the hood to disconnect the battery for the Kicker subwoofer install I found the ground terminal was loose. It moved when I put the socket on it.

Since the subwoofer install and getting both battery terminals tight I haven’t experienced anymore electrical oddities. Your mileage may vary, but it’s worth popping the hood and checking.
 
Well back from the dealer with a new radio. Seems I have a new problem unless this is a new feature or option I’m unaware of.

The right hand menu that shows the clock, radio, map etc. seems to be gone.

CarPlay however is full screen now.

Anyone experience this?
 

Attachments

  • image.jpg
    image.jpg
    233.3 KB · Views: 68
  • image.jpg
    image.jpg
    232.1 KB · Views: 67
Interesting. At least the map in CarPlay isn’t stretched out looking. Although that looks like Google Maps. I use Waze with CarPlay. Every once in awhile I get full screen CarPlay, but it’s usually after going from reverse to drive right after the cameras switch to the infotainment screen. The Waze map looks stretched out during this brief full screen. But it quickly goes back to normal small CarPlay screen.
 
Interesting. At least the map in CarPlay isn’t stretched out looking. Although that looks like Google Maps. I use Waze with CarPlay. Every once in awhile I get full screen CarPlay, but it’s usually after going from reverse to drive right after the cameras switch to the infotainment screen. The Waze map looks stretched out during this brief full screen. But it quickly goes back to normal small CarPlay screen.
That’s Waze. Right from CarPlay. The menu seems to be completely gone. No indication of how to enable it.

If it’s not one thing it’s another I swear
 
Well back from the dealer with a new radio. Seems I have a new problem unless this is a new feature or option I’m unaware of.

The right hand menu that shows the clock, radio, map etc. seems to be gone.

CarPlay however is full screen now.

Anyone experience this?
Is there a setting to change the appearance and have the right side screen show-up?
 
Is there a setting to change the appearance and have the right side screen show-up?
Nothing In settings at all. Seems the android version is even older than my other head unit.

Very strange. Seems I can’t win the infotainment game.
 

Attachments

  • 674A8786-70F1-49C9-8911-E1DDFCBD6956.jpeg
    674A8786-70F1-49C9-8911-E1DDFCBD6956.jpeg
    76.5 KB · Views: 38
  • 3218AFD0-A7F5-45D1-9DDF-1E68809B45D8.jpeg
    3218AFD0-A7F5-45D1-9DDF-1E68809B45D8.jpeg
    94.6 KB · Views: 38
Well back from the dealer with a new radio. Seems I have a new problem unless this is a new feature or option I’m unaware of.

The right hand menu that shows the clock, radio, map etc. seems to be gone.

CarPlay however is full screen now.

Anyone experience this?
I think when you are using the normal google maps the arrow on the right side of the screen needs to be pressed to get the right screen back.

For those that want either Apple or Android maps to show a fullish screen, you have to tap the icon for the map 2x to make it larger.
 

Most Member Reactions

Back
Top