Well looks like in to the shop goes another one

KevO16

Member
Founding Member
Joined
Apr 18, 2022
Messages
45
Reaction score
91
Location
Southwest Ohio
So I’ve already had my battery die 4 times on me in a year - 2 warm weather, 2 cold weather. Today was number 4.

Story goes like this. When I got home yesterday an update came up but when I tapped install (in my driveway, parked, after I got home from 4 hours of driving around) it said it couldn’t complete at that time even though it had just popped up after I parked. Later, I noticed some weird stuff whenever I’d get in the vicinity of the truck (leaving/coming home in my wife’s car) the lights flashed 4 or 5 times with no key presses, but no horns, no mirror folding, nothing. Key fobs still worked at that time because I relocated just in case. Last time I brought it in for recalls, I tried to schedule electrical evaluation the same day because of the dead batteries and they told me they needed a few days to search for an electrical problem, but had no loaners so I had to schedule for the future.

Today, tried to remote start x2 via app with no luck - usually no problems. Tried it from both key fobs, nothing. Doors wouldn’t open, had to manually turn the key to get inside. Dash was completely dead when I opened the door. Jumped it and it turned on with various errors I’ve seen before the last times such as “service steering column lock,” “abs failure speed limited to 47 mph” ….and subsequently 35 mph, but a new one about power steering being out flashed up and went away. The battery was DEAD because I had to wait about 3 minutes with my charger on before the dash would stay up and it’s an 80000mAh battery jumper so it powers the truck by itself usually - the last few jumps at least.

So we were started. I began driving down the driveway…Welp, power steering is dead. Then, as I tried to figure out what was next, the dash said “power steering failure. No assist soon.” Service doesn’t open until 9, but essentially it’ll need to be towed in, but I’m done playing nice. This is ridiculous for a $70,000+ truck. I logged in today to 3 posts of trucks in the shop for weeks with various repairs. This is unacceptable for such expensive trucks.

Wondering if anybody else has been having severe electrical issues like this…?
 
Very sorry to hear your story. All you can do is hope the dealership does a good job fixing it now....
 
Sounds like a bad update or flash.

I do wish GM would offer physical updates that can be downloaded and installed via USB. Ford offers this and honestly is the only way I’ve ever been able to successfully update SYNC.

OTA leaves lots of room for issues without checksum’s or file verification.

I performed exactly one “mandatory” OTA update and basically bricked the radio in my truck.

Hope it gets all sorted out for you.
 
  • Like
Reactions: AXE
So I’ve already had my battery die 4 times on me in a year - 2 warm weather, 2 cold weather. Today was number 4.

Story goes like this. When I got home yesterday an update came up but when I tapped install (in my driveway, parked, after I got home from 4 hours of driving around) it said it couldn’t complete at that time even though it had just popped up after I parked. Later, I noticed some weird stuff whenever I’d get in the vicinity of the truck (leaving/coming home in my wife’s car) the lights flashed 4 or 5 times with no key presses, but no horns, no mirror folding, nothing. Key fobs still worked at that time because I relocated just in case. Last time I brought it in for recalls, I tried to schedule electrical evaluation the same day because of the dead batteries and they told me they needed a few days to search for an electrical problem, but had no loaners so I had to schedule for the future.

Today, tried to remote start x2 via app with no luck - usually no problems. Tried it from both key fobs, nothing. Doors wouldn’t open, had to manually turn the key to get inside. Dash was completely dead when I opened the door. Jumped it and it turned on with various errors I’ve seen before the last times such as “service steering column lock,” “abs failure speed limited to 47 mph” ….and subsequently 35 mph, but a new one about power steering being out flashed up and went away. The battery was DEAD because I had to wait about 3 minutes with my charger on before the dash would stay up and it’s an 80000mAh battery jumper so it powers the truck by itself usually - the last few jumps at least.

So we were started. I began driving down the driveway…Welp, power steering is dead. Then, as I tried to figure out what was next, the dash said “power steering failure. No assist soon.” Service doesn’t open until 9, but essentially it’ll need to be towed in, but I’m done playing nice. This is ridiculous for a $70,000+ truck. I logged in today to 3 posts of trucks in the shop for weeks with various repairs. This is unacceptable for such expensive trucks.

Wondering if anybody else has been having severe electrical issues like this…?
So sorry you are going through that! I’ve been so torn on how much too push the buyback on mine because I like the truck so much, but like you said about all the other problems people are having, it will be taking a big risk to just accept my truck back after the new engine is installed. Good luck and I hope they finally get you taken care of!
 
One week at the dealership already. So far they’ve only been able to tell me my battery was fully discharged twice, but its health is “good” and they didn’t seem to think a fully dead battery twice in 3 days was an issue. They performed my second service and jumped it and tried to call me to tell me it was ready…uhhh, no. 6 times dead now in 11 months. I don’t think that’s normal.
 
One week at the dealership already. So far they’ve only been able to tell me my battery was fully discharged twice, but its health is “good” and they didn’t seem to think a fully dead battery twice in 3 days was an issue. They performed my second service and jumped it and tried to call me to tell me it was ready…uhhh, no. 6 times dead now in 11 months. I don’t think that’s

One week at the dealership already. So far they’ve only been able to tell me my battery was fully discharged twice, but its health is “good” and they didn’t seem to think a fully dead battery twice in 3 days was an issue. They performed my second service and jumped it and tried to call me to tell me it was ready…uhhh, no. 6 times dead now in 11 months. I don’t think that’s normal.
that sucks...any other dealers in your area?
 
One week at the dealership already. So far they’ve only been able to tell me my battery was fully discharged twice, but its health is “good” and they didn’t seem to think a fully dead battery twice in 3 days was an issue. They performed my second service and jumped it and tried to call me to tell me it was ready…uhhh, no. 6 times dead now in 11 months. I don’t think that’s normal.
Parasitic draw.....
 
Had the same issue with our 2020 Rubicon. Dealer kept saying it was defective batteries and replaced them without actually figuring out what was wrong. The 5th time it happened, dealer said the same thing. I refused to pick it up until it was actually fixed. It sat there for 2 weeks and then they told me it needed a software update. Jeep ended up buying it back as a lemon
 
that sucks...any other dealers in your area?
Yeah I have a few others. This is one of the largest in Ohio and where I bought it so I figured when you’re spending $72K on a truck they’d be more willing to maybe go the extra mile. So far it’s looking like I won’t buy from them again only because of the service department. I have messaged my service advisor 4 times today with no updates since yesterday afternoon when she was “checking with the technician for an update.”
 
Had the same issue with our 2020 Rubicon. Dealer kept saying it was defective batteries and replaced them without actually figuring out what was wrong. The 5th time it happened, dealer said the same thing. I refused to pick it up until it was actually fixed. It sat there for 2 weeks and then they told me it needed a software update. Jeep ended up buying it back as a lemon
Ithink that’s unfortunately where we may be headed here if they can’t figure it out
 
Parasitic draw.....
This is what I’m thinking, but where from is the big question. I’m not going to be the one tearing this truck apart to search for it at 11 months of ownership and under every existing warranty.
 
  • Like
Reactions: AXE
Yeah I have a few others. This is one of the largest in Ohio and where I bought it so I figured when you’re spending $72K on a truck they’d be more willing to maybe go the extra mile. So far it’s looking like I won’t buy from them again only because of the service department. I have messaged my service advisor 4 times today with no updates since yesterday afternoon when she was “checking with the technician for an update.”
good luck bro.
 
@Kev016...feeling your pain, I am going to pick up my 23 tonight from dealership. After discussing what happened with the service advisor today, they have came to the conclusion that the mandatory OTA and possibly the DRL OTA bricked my electrical system via parasitic draw...also started having brake controller issues after both updates. I haved owned this truck for 3 months and just rolled over 2100 miles...I will post later on tonight what was found when I get my service invoice....I had a post started under Doornail Dead ZR2. OTA has been deactivated since I live about 30 mi from the dealership. Hang in there and will update my post later.👍
 

Most Member Reactions

Back
Top