Annoying Rattle

Koboss

New member
Joined
Mar 7, 2023
Messages
10
Reaction score
15
Location
Ontario Canada
I have an Annoying Rattle that sounds like it is coming from the front passenger Pilar where the hand grab is, anyone else have a rattle on the front passenger side i have taken the covers off the grab handle to see if it is a nut bouncing around in there but its not, im wondering if it is the plastic above the air vent but again havent pin pointed it yet

dont have time to run it to the dealer a hr away yet

thanks
 
I have an Annoying Rattle that sounds like it is coming from the front passenger Pilar where the hand grab is, anyone else have a rattle on the front passenger side i have taken the covers off the grab handle to see if it is a nut bouncing around in there but its not, im wondering if it is the plastic above the air vent but again havent pin pointed it yet

dont have time to run it to the dealer a hr away yet

thanks
Man let me tell you, lol. I have one on the driver's side. I thought it was in that same area by the grab handle. I replaced my speakers and added tweeters there. So I thought it was the tweeter at first, than I thought it was wire mounts behind that trim. Than I thought maybe it was in the area of the dash speaker. Long story short. I've taken that apart probably 6 times and now I think its actually the trim panel around the instrument cluster, which has nothing to do with the speakers I replaced. It doesn't always do it, and its only while driving. So it's been hard to track down. I drove my truck around with both A-pillar trims and the top section of the dash removed trying to find it, lol. It still did it. Pushed and pulled on the glossy black plastic by the vent and it got better. Probably no help to you since yours is on the passenger side. But I'd say maybe start around the vent area. I got excited when I seen the thread title, Cause I was hoping it was in the same area.
 
  • Like
Reactions: AXE
Man let me tell you, lol. I have one on the driver's side. I thought it was in that same area by the grab handle. I replaced my speakers and added tweeters there. So I thought it was the tweeter at first, than I thought it was wire mounts behind that trim. Than I thought maybe it was in the area of the dash speaker. Long story short. I've taken that apart probably 6 times and now I think its actually the trim panel around the instrument cluster, which has nothing to do with the speakers I replaced. It doesn't always do it, and its only while driving. So it's been hard to track down. I drove my truck around with both A-pillar trims and the top section of the dash removed trying to find it, lol. It still did it. Pushed and pulled on the glossy black plastic by the vent and it got better. Probably no help to you since yours is on the passenger side. But I'd say maybe start around the vent area. I got excited when I seen the thread title, Cause I was hoping it was in the same area.
Man let me tell you, lol. I have one on the driver's side. I thought it was in that same area by the grab handle. I replaced my speakers and added tweeters there. So I thought it was the tweeter at first, than I thought it was wire mounts behind that trim. Than I thought maybe it was in the area of the dash speaker. Long story short. I've taken that apart probably 6 times and now I think its actually the trim panel around the instrument cluster, which has nothing to do with the speakers I replaced. It doesn't always do it, and its only while driving. So it's been hard to track down. I drove my truck around with both A-pillar trims and the top section of the dash removed trying to find it, lol. It still did it. Pushed and pulled on the glossy black plastic by the vent and it got better. Probably no help to you since yours is on the passenger side. But I'd say maybe start around the vent area. I got excited when I seen the thread title, Cause I was hoping it was in the same area.

I have an Annoying Rattle that sounds like it is coming from the front passenger Pilar where the hand grab is, anyone else have a rattle on the front passenger side i have taken the covers off the grab handle to see if it is a nut bouncing around in there but its not, im wondering if it is the plastic above the air vent but again havent pin pointed it yet

dont have time to run it to the dealer a hr away yet

thanks

I have an Annoying Rattle that sounds like it is coming from the front passenger Pilar where the hand grab is, anyone else have a rattle on the front passenger side i have taken the covers off the grab handle to see if it is a nut bouncing around in there but its not, im wondering if it is the plastic above the air vent but again havent pin pointed it yet

dont have time to run it to the dealer a hr away yet

thanks
Not sure if this helps, but will put it out there, just in case. I found a slight rattle that had to do with the driver side adjustable seatbelt area. Would suggest checking there and messing around with that.
 
I know this doesn't help, but I hear a rattle sound coming from the driver's side back seat when driving. I've looked for and tightened any bolt/screw I could find and it still happens. So I just turn up the stereo loud enough so I don't hear it!
 
Have you tried the plastic trim that's just behind the rear view mirror? That rattles at times along with the trim around the HUD for me.
 
I know this doesn't help, but I hear a rattle sound coming from the driver's side back seat when driving. I've looked for and tightened any bolt/screw I could find and it still happens. So I just turn up the stereo loud enough so I don't hear it!
I have a rattle in the same area and tracked it down to the head rest rods. The rattle only happens when the seat behind the driver is unoccupied. Hope this helps.
 
  • Like
Reactions: AXE
I had this problem on the driver side. This is how I fixed.

The latch that is located on the apillar is adjustable. There are two torque bolts, I think T40. Do not remove these bolts all the way! Loosen them a bit and the latch will slide up or down. I put a peace of tape on the bottom of the latch attached to the apillar for reference. I moved the latch up an 1/8 of an inch maybe 3/16’s and no more squeak.

Hope that helps.
 
Fwiw, I Seem to have fixed mine. I'm not really even sure what fixed it. I removed a lot of the dash and just went over everything. Anything lose or that looked like it could rattle I tried to secure it. Guess it worked. Drove a decent amount the past few days and no more rattle. So mine was definitely something in the driver's side dash area, just don't know what lol.
 
Found the nose, it was a loose wire loom in the windshield Pillar, the plastic push pin that holds the woom in place came loose about a 1/8th" and let the wire loom rattle, pushed it back in and put some gorilla tape on the wires to the metal frame, thanks for the help to all replies
 

Attachments

  • A11.jpg
    A11.jpg
    58.3 KB · Views: 30
  • A12.jpg
    A12.jpg
    169 KB · Views: 31
I replaced those pins with the two piece ones. Like what chevy used under the hood in the engine bay. I also had a couple that were loose.
 
  • Like
Reactions: AXE

Most Member Reactions

Back
Top