Internet issues

landpilot

Active member
Founding Member
Joined
Jun 14, 2022
Messages
165
Reaction score
201
Location
Kentucky
Today the internet went completely out in the truck. The wifi hotspot inside the truck works, but the cellular internet quit. I checked my account with chevy/onstar, and it says that I have unlimited data, so it's not like they shut it off for non-payment. Anything that uses the truck's data is not functioning... none of the Google apps work, none of the apps I've downloaded work, and even OnStar is non-functional. (I didn't try the SOS button.) The only way I can get anything to work is if I'm connected to my home wifi in the driveway, but even then OnStar is still dead.

Guess it's off to the dealer I go... anyone else had this issue? None of this crap started until they did their OTA update a couple of weeks ago.
 
I spent some time researching this last night. The 2021 models had a TSB (#20-NA-221) for vehicles that had internet connectivity issues that caused OnStar and other apps to stop working. I know our trucks have a different infotainment system, but the symptoms are incredibly similar. Does anyone here who works at a dealership or for GM know of a TSB similar for our trucks? The fix was a reprogram of the radio by the service department. Just thought I'd check before I take it in...

Thanks in advance!
-Chuck
 
Mine also has quit as well same exact symptoms as you listed hopefully something simple I’m heading to dealer in morning
 
Mine also has quit as well same exact symptoms as you listed hopefully something simple I’m heading to dealer in morning
I’m going Friday. If you don’t mind please post back what they say. Thanks!!
 
well, they kept mine to do some more diagnosis. Plus, there is apparently a recall for some spacers on the heat shield for the spare tire? They are going to do that as well.
 
It turns out the OnStar module has gone out on my truck. Dealer had to order it. I've had this happen on one other GM truck as well. Hopefully that takes care of the problem, should know in a week or two.
 
It turns out the OnStar module has gone out on my truck. Dealer had to order it. I've had this happen on one other GM truck as well. Hopefully that takes care of the problem, should know in a week or two.
That sucks I guess I got lucky with just a reload of the software
 

Most Member Reactions

Back
Top